Revision history   OpenPOWER Library

 5.2. OpenPOWER Ready Criteria for CAPI Applications

The application code running on an OpenPOWER Ready operating system on an OpenPOWER Ready system is uniquely tied to Accelerated Functional Units (AFUs) that implement the accelerated services it requires. OpenPOWER Ready applications and/or AFUs must meet the following criteria:

  1. Use of an OpenPOWER Ready CAPI adapter per Section 5.1, “OpenPOWER Ready Criteria for CAPI Adapters”.

  2. Accelerated Functional Units (AFUs) must communicate with the IBM licensed Power Service Layer (PSL) using the PSL/AFU Interface.

    The PSL Simulation Engine (PSLSE) or equivalent method may be used to verify that the AFU correctly implements the PSL/AFU Interface. The PSLSE is available via GITHUB at https://github.com/ibm-capi/pslse.

  3. Applications and/or interface libraries running on the OpenPOWER host should use an API library which satisfies the CAIA to control and communicate with supporting AFUs.

    [Note]Note

    The open source CAPI library libcxl may be used and assumed compliant with CAIA.